Aller au contenu


[Correctif externe] Pnj Qui Ne S'assoit Pas Ou Il Faut


  • Veuillez vous connecter pour répondre
15 réponses à ce sujet

#1 Lord Jeodith

Lord Jeodith

Posté 08 février 2014 - 14:21

Bonjour, donc en fait j'ai créé un mod il y a peu pour remplacer l'ancien qui était trop bugué, avec regrets..

Dans ce mod d'habitation j'ai placé quelques gardes qui font leurs packages sans soucis, seulement une fois sur deux j'ai un bug..
En fait mes pnjs ne s'assoient pas correctement sur leurs chaises, ou même au moment d'aller dormir ne dorment pas sur leurs lits mais à côté des lits, et je trouve ça un peu nul..

Je vous laisse une petite photo histoire que vous compreniez mieux, car je n'ai rien trouvé qui me permette d'avancer.

Posted Image

A propos j'utilise le PNOS, mais je ne sais pas si le Patch Non Officiel de Skyrim corrige ce genre de soucis.

Modifié par Lord Jeodith, 08 février 2014 - 14:22.

également FheralGhoul666 sur La Confrérie des Traducteurs

#2 Nico coiN

Nico coiN

    Commissaire Magret


Posté 08 février 2014 - 15:17

C'est un problème bien connu du moteur de jeu, et donc impossible à corriger.

Posted Image

Posted Image

Posted Image

Les causes peuvent être variées : activateurs (chaises, lits) défaillants (possible si ce sont de nouveaux meshes), autres meubles trop proches et pouvant perturber la cohabitation des divers éléments, géométrie (et plus particulièrement les angles/l'orientation des éléments) mal gérée par le moteur de jeu (comme ce qui arrive avec les mannequins/bibliothèques/râteliers d'armes du jeu vanilla).
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#3 Lord Jeodith

Lord Jeodith

Posté 08 février 2014 - 15:43

Non il n'y a pas de nouvelles meshes toutes les chaises et les lits, sont des objets vanilla comme d'ailleurs tout le reste de mon mod hormis quelques tableaux que j'ai rajouté pour la déco, et le seul meuble qui est a côté des chaises est une table ( comme sur la photo )
Et je doute que ça soit qui fasse buguer, enfin j'en sais rien Skyrim est tellement bugué..

Je vais tenter d'éloigner un peu plus les chaises de la table, qui sait.. ( ou changer peut être aussi les meubles..)
c'est drôle d'ailleurs car j'ai utilisé le même mobilier que celui qui est dans le Fort Dragon à Blancherive, et la bas rien ne bugue en jeu..

Enfin j'avoue que c'est un probléme particulier..

C'est aussi ce probléme qui fait buguer les mannequins ? car les mannequins que j'ai mis buguent aussi malgré le script que j'ai trouvé sur le nexus qui corrige un autre probléme ( le déplacements des mannequins, ça c'est ok c'est reglé)
Mais par contre il arrive souvent que l'option qui permet d'intéragir avec eux pour les habiller , ne soit pas à l'emplacement du mannequin mais souvent 5 metres plus loin...

Ce qui est bizare.., mais il suffit de quitter la cellule et d'aller dehors pour corriger le probléme ( de maniére temporaire )

Modifié par Lord Jeodith, 08 février 2014 - 16:02.

également FheralGhoul666 sur La Confrérie des Traducteurs

#4 Nico coiN

Nico coiN

    Commissaire Magret


Posté 08 février 2014 - 17:13

View PostLord Jeodith, on 08 février 2014 - 15:43, said:

C'est aussi ce probléme qui fait buguer les mannequins ?

Je ne sais pas, mais l'orientation des éléments a son importance. Le bug du moteur de jeu est connu. Je vais essayer de ne pas m'embrouiller les pinceaux en l'expliquant.

Pour des statics avec lesquels il est impossible d'interagir il n'y a aucun problème. Pour des activateurs spécifiques (lits, sièges divers, bibliothèques, mannequins, râteliers d'armes...) le moteur de jeu va chercher les coordonnées scalaires et polaires du static de base. En effet, s'il faut 'rajouter' un personnage ou un objet sur le static de base il est intéressant que le moteur les place de manière 'alignée', tu me suis ?

Eh bien c'est là qu'est le bug ! Le moteur gère très mal les coordonnées polaires. Il ne suffit pas de faire un copier-coller des coordonnées polaires du static d'origine et de les injecter dans le nouvel objet/personnage à rajouter dessus. Pour les râteliers d'armes, par exemple, il faut rajouter 90° ou 180 ° pour certaines armes sinon on obtient ça :

Posted Image

L'USKP tente d'ailleurs de corriger ça avec plus ou moins de succès... Posted Image Mais dans le moteur de jeu les fonctions trigonométriques inverses peuvent tout à fait provoquer ce genre de bug (décalages de 90 ou 180°), surtout si en plus certaines valeurs flottantes sont interprétées négativement au-delà d'un certain seuil (ça aussi, c'est connu). Si tu me demandes quel angle a un sinus de 0 je te répondrai qu'il y a 2 possibilités : 0 ° et 180 °. Eh bien le moteur de jeu connaît ces deux solutions, sauf qu'il ne choisit pas toujours la bonne... Posted Image Ça peut aussi expliquer des décalages personnages/supports divers comme le mannequin de droite :

Posted Image

Une des ruses pour 'leurrer' le moteur de jeu consiste à tourner l'activateur de départ de 3 ou 4 degrés maxi, justement pour essayer de ne pas tomber sur des valeurs 'à problème'. En théorie ça marche... ou pas... Posted Image Une autre ruse consiste à décaler le North Marker de ton intérieur de 3 ou 4 degrés (car lui aussi entre en compte dans les algorithmes) pour les mêmes raisons. Là aussi ça devrait marcher en théorie... ou pas... Posted Image

Le moteur de jeu de Skyrim/Havok est buggué et il n'y a pas grand-chose à faire. Le problème était déjà présent dans Oblivion bien que moins visible (car pas de mannequins ni de râteliers d'armes).

Posted Image

Et dans FNV le moteur faisait aussi des trucs bizarres (c'était peut-être aussi lié à des drivers) :



Bref, pas de solution vraiment probante...
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#5 Lord Jeodith

Lord Jeodith

Posté 08 février 2014 - 21:26

Le bug la, avec la plaque de présentation je l'ai déjà eu et du coup j'ai viré les plaques d'armes en question de mon mod..

L'orientation des éléments ? aie il suffirait donc qu'un objet soit mal orienté pour que cet objet se mette a buguer..
j'en avais déjà entendu parler par un gars de J.V.com, ( en ce qui concerne les mannequins )
j'ai de la chance car depuis que j'ai décalé les siéges cela ne semble plus buguer, idem pour les lits.. (enfin du moins pour l'instant )

En fait je n'ai que les mannequins qui sont bugués,
pourtant ils ne bougent jamais mais il y a quand même ce bug qui empêche d'intéragir avec eux directement,
de toute façon il y a une solution temporaire pour les mannequins..

Mais c'est embétant pour le reste que le moteur graphique soit si bugué qu'il s'agisse d'Oblivion même si ça se voit moins
ou encore Skyrim ou la c'est largement visible, mais j'ai toutefois un peu de mal a te suivre avec cette histoire de coordonnées polaires..
enfin c'est comme ça, si par contre l'USKP tente de corriger ça je vais prendre soin de savoir ce que c'est..

Par contre l'histoire de décaler de 3 ou 4  degrés le Marqueur Nord ça je n'y avais pas pensé, ça peut toujours s'essayer.

Bon en fait je m'étais trompé ça bugue toujours..
Bref qu'importe si ça peut pas se corriger, tant pis..

Par contre ce patch l'USKP vu qu'il est surement américain ou russe, Est-ce qu'on peut l'utiliser ?

Modifié par Lord Jeodith, 08 février 2014 - 21:26.

également FheralGhoul666 sur La Confrérie des Traducteurs

#6 Nico coiN

Nico coiN

    Commissaire Magret


Posté 08 février 2014 - 21:39

Hum... Toi, tu n'es pas venu sur Wiwiland depuis un moment... :shock:

Jette un oeil à ça, et lis ce qu'il y a après les images. :D
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#7 Lord Jeodith

Lord Jeodith

Posté 13 février 2014 - 20:01

A vrai dire je ne viens plus tellement souvent, je reprends juste le modding depuis quelques temps..

Vraiment très drôle le début.. :mdr:


Inutile de chercher a utiliser l' USKP si il est déjà intégré au PNOS 2.0.0a
je me rends compte d'ailleurs que le PNO que j'utilise avec Skyrim est le 2.0.0a
Donc en fait j'avais déjà les correctifs de l'USKP avant d'en parler, donc il n'y a vraiment rien a faire contre ces bugs..

Puisque l'USKP qui est déjà présent dans les patchs de mon jeu ne semble pas pouvoir le corriger..




Voila le bug dont je parlais avec les mannequins, est-ce que ça a un rapport avec le moteur physique du jeu ?

Posted Image  

On peut remarquer sur la photo ou s'affiche l'option " parler à mannequin " et que son emplacement est tout sauf normal..
Car cette option normalement ne devrais s'afficher que quand on est face au mannequin..

Modifié par Lord Jeodith, 13 février 2014 - 20:07.

également FheralGhoul666 sur La Confrérie des Traducteurs

#8 Nico coiN

Nico coiN

    Commissaire Magret


Posté 13 février 2014 - 20:14

Absolument aucune idée. Mais dans le jeu vanilla les seuls mannequins qu'on trouve sont ceux dans les maisons que le joueur peut acheter (plus un au fort de la garde de l'aube), donc ce que tu nous montres vient d'un mod.

Et les mannequins de ce mod utilisent-ils les scripts vanilla ou, à défaut, ceux de l'USKP ? :shock:

Je n'utilise que des mods cosmétiques, et je n'ai absolument jamais vu ça...

De même, le mannequin au premier plan tourne la tête, ce qui au regard du jeu en fait un PNJ, et non un activateur... La position des bras et des mains ne me paraît pas non plus 'naturelle'. Ça sent le mod de mannequin foireux qui annule les modifs apportées par l'USKP (si tu l'utilises)... :hum:
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#9 Lord Jeodith

Lord Jeodith

Posté 13 février 2014 - 20:36

Non en fait on m'a donné un lien pour un script trouvé sur Nexus qui corrige le déplacement des mannequins,
et en effet avec ce script les mannequins ne se déplacent plus..
Seulement il arrive parfois que ceux la tournent la tête, prénnent des poses, mais j'avais déjà ce bug avant l'utilisation de ce script.. (le bug de la photo )
Je pourrais enlever ce script que cela ne changerais pas grand chose et que j'aurais toujours le même problème que sur la photo...

Les mannequins viennent d'un mod ( le miens.. )
un mod d'habitation ou presque tout est vanilla y compris les mannequins,
la seule chose qui n'est pas vanilla dans mon mod sont des tableaux statiques que j'ai trouvé comme ressource sur le Nexus et que j'ai rajouté a mon mod
( des tableaux de paysages de Skyrim..)
Hormis ça j'ai modifié également quelques murs avec Nifskope pour un soucis de rateliers, mais rien d'autre tout le reste est purement et simplement vanilla..
D'ailleurs les murs qui sont juste derrière les mannequins sont également des murs vanilla..

Sur ma partie je n'utilise rien d'autre a part mon mod que j'ai nommé " Le Fort d'Ombrelune " le PNOS 2.0.0a et ce script c'est tout, voila..


Est-ce une erreur d'utiliser ce script qu'on m'a conseillé ?

Modifié par Lord Jeodith, 13 février 2014 - 21:50.

également FheralGhoul666 sur La Confrérie des Traducteurs

#10 Nico coiN

Nico coiN

    Commissaire Magret


Posté 13 février 2014 - 21:36

Le correctif inclus dans l'USKP est normalement auto-suffisant :

Quote

v1.2.4 - (2012-11-21)
Script Fixes
  • MannequinActivatorSCRIPT.psc should no longer allow equipment duplication to occur or for mannequins to wander from their platforms.
Tout autre mod altérant aussi ce script en annule donc purement et simplement les correctifs. Et comme une grande partie de ce qui touche aux scripts reste incrustée dans les sauvegardes...

Le mieux est d'envoyer ton mod à quelques personnes qui ont une install' relativement 'clean' et de voir quels sont leurs retours.
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#11 Lord Jeodith

Lord Jeodith

Posté 13 février 2014 - 21:59

Pourquoi la mienne ne te parait pas clean ?
car enlever le script de Nexus du dossier Data je peux le faire, recommencer une nouvelle partie je le peux aussi
et réinstaller le jeu proprement je le peux également.. ( et ça ne sera pas la première fois..)

Enfin bon si le mieux et d'envoyer ce mod a quelques personnes histoire de voir ce qu'il en est, je le ferait..
également FheralGhoul666 sur La Confrérie des Traducteurs

#12 Nico coiN

Nico coiN

    Commissaire Magret


Posté 13 février 2014 - 22:06

Ton install' semble 'clean', ce n'est pas le problème. Mais ta partie en cours ne l'est apparement pas, probablement à cause de ce script. C'est tout ce que je voulais dire, rien d'autre.
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#13 Lord Jeodith

Lord Jeodith

Posté 13 février 2014 - 22:10

Ha ok
également FheralGhoul666 sur La Confrérie des Traducteurs

#14 Nico coiN

Nico coiN

    Commissaire Magret


Posté 13 février 2014 - 22:23

Ne te tiens également pas à une seule source pour le design des mannequins. Je n'y connais rien, mais cette vidéo a l'air vraiment pas mal :


Et elle expose un moyen alternatif d'empêcher les mannequins de bouger : les isoler dans une 'île' de navmesh.
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.

#15 Lord Jeodith

Lord Jeodith

Posté 15 février 2014 - 17:32

Merci pour la vidéo, même si je ne comprends pas un chouilla d'anglais j'ai quand même compris ce que tu disais par " isoler " les mannequins  dans une île de navmeshs
Et je vais donc travailler sur le c.k à partir de ça, tout en prenant soin de recommencer une nouvelle partie pour éviter que ma save soit corrompue par l'ancien script..


Bon a partir d'une nouvelle partie..
J'ai essayé la méthode indiqué sur la vidéo, enfin d'isoler les mannequins avec les navmeshs et c'est encore pire qu'avant,
et a moins qu'il ne dise dans sa vidéo quelque chose de particulier ou comment régler ce probléme.. ( qui est en photo )
Je me retrouve avec des mannequins avec lesquels je ne peux plus intéragir, et le probléme est pire qu'avant
pourtant je peux régler le probléme en sortant, mais cela ne marche pas a tout les coups..


Posted Image

Je vais réinstaller Skyrim, histoire de voir si ça change quelque chose ou encore le faire tester par quelqu'un
oh et désolé si je suis nul en anglais..

______________________________________



Le test de mon mod par quelqu'un d'autre est en cours, afin de vérifier si les mêmes bugs apparaissent sur une autre partie que la mienne...
Et j'ai réussi a corriger ce probléme de mannequins...

Enfin je parle du problème que j'ai eu lorsque j'ai voulu entourer mes mannequins d'un îlot de navmeshs afin d'empêcher leurs déplacements,
il m'a suffit de tout retirer autour des mannequins..
Mon autre problème qui apparaissait sur l'autre photo n'est plus d'actualité, car ça ne l'a pas refait
( du moins pour l'instant.....)
Peut être le problème venait-il du script trouvé sur Nexus..?

En voici le lien :
http://www.nexusmods...im/mods/10652/?

Du coup je n'utilise plus rien a part le PNOS qui apparemment contient déjà un patch pour le problème des mannequins..
Et tout avis la dessus sera le bienvenu !

Modifié par Lord Jeodith, 15 février 2014 - 17:43.

également FheralGhoul666 sur La Confrérie des Traducteurs

#16 Nico coiN

Nico coiN

    Commissaire Magret


Posté 06 mai 2015 - 20:23

Oyez, oyez. Le problème d'origine de ce topic est résolu depuis environ un an grâce à un plugin SKSE. Ce correctif ne sera donc pas inclus dans le PNOS. D'une manière générale, les correctifs non inclus dans le PNOS/USKP sont listés ici.
Canard mystique, grand instigateur et créateur de la carpe d'ondepluie.




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)