Aller au contenu


[Résolu]Problème Sauvegarde Script


  • Veuillez vous connecter pour répondre
5 réponses à ce sujet

#1 -Prechan-

-Prechan-

Posté 15 décembre 2010 - 20:24

Bonjour à tous et à toutes,

Je me suis mis au GECK Vegas depuis sa sortie. Suite à un petit mod d'habitation, et comme j'avais du temps, j'ai voulu en faire un autre. Etant un habitué du TESC, et voulant ici faire un script simplissime, je me dis ça va pas être très dur.

Je le met en forme, mais au moment de le sauvegarder (l'activation de la touche disquette ne faisant rien d'apparent) le GECK me demande si je veux sauver le "Current Script = [VIDE]" je dis oui, et là paf, rien, je reste dans l'éditeur de script, et impossible de fermer sans perdre le script.

Je n'ai jamais eu cette petite mésaventure auparavant. Ci-suis mon script.

Merci de votre aide, Prechan

scn aaaPHHHDoorHouse01

	; Script de la porte de la maison de McLich

Begin OnActivate

	If IsActionRef Player == 1
		
		MessageBox  "Cette porte est scellée, cependant, quelquechose me dit de passer par le cimetière de Goodsprings..."

	Else
		
		Activate

	Endif

End

<<< Le Repaire de Prechan >>>
Mon Site...avec toutes les news du développement de mes mods et plein d'autres trucs (La Bière n'est servie qu'aux Nains !)

#2 Ridiane

Ridiane

Posté 15 décembre 2010 - 20:36

Le GECK est buggé. Il n'affiche aucun message de debug, pour les scripts comme pour la plupart du reste, comme ton script comporte une erreur il ne le compile et donc ne le sauvegarde pas.

Ceci corrige le problème, mais n'est pas compatible avec NVSE.

Sinon, si il s'agit d'une erreur ne venant pas des références incluse dans ton script tu peux utiliser ceci aussi.

Une nouvelle version du GECK est prévue prochainement apparemment, j'espère qu'elle corrigera ce problème.

#3 -Prechan-

-Prechan-

Posté 15 décembre 2010 - 20:55

Mon script comporte une erreur ?  :?:
<<< Le Repaire de Prechan >>>
Mon Site...avec toutes les news du développement de mes mods et plein d'autres trucs (La Bière n'est servie qu'aux Nains !)

#4 Ridiane

Ridiane

Posté 15 décembre 2010 - 21:00

Oui c'est qu'il y'a une erreur  :). Où ? je ne saurais te dire comme ça, mais c'est pour ça qu'il ne le sauvegarde pas.

#5 Shadow she-wolf

Shadow she-wolf

    Le katana de la GBT


Posté 15 décembre 2010 - 21:02

View Post-Prechan-, on 15 décembre 2010 - 20:55, said:

Mon script comporte une erreur ?  :?:
MessageBox n'existe plus dans le Geck.

On doit maintenant écrire un message, et l'appeler avec la fonction ShowMessage.

#6 -Prechan-

-Prechan-

Posté 15 décembre 2010 - 21:09

View PostShadow she-wolf, on 15 décembre 2010 - 21:02, said:

View Post-Prechan-, on 15 décembre 2010 - 20:55, said:

Mon script comporte une erreur ?  :?:
MessageBox n'existe plus dans le Geck.

On doit maintenant écrire un message, et l'appeler avec la fonction ShowMessage.

Merci à toi Shadow !
C'est bien plus compliqué, mais enfin c'est la vie ;)
<<< Le Repaire de Prechan >>>
Mon Site...avec toutes les news du développement de mes mods et plein d'autres trucs (La Bière n'est servie qu'aux Nains !)




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)