Aller au contenu


[résolu] Mes Créatures Fuient... Au Lieu De Combattre


  • Veuillez vous connecter pour répondre
5 réponses à ce sujet

#1 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 07 avril 2009 - 05:45

Bonjour,

J'essaye d'ajouter de nouvelles créatures au jeu, il s'agit là de geckos.

Le problème, c'est qu'il se barrent au lieu de se battre. Pourtant Ils ont dans la page AI Data la même chose que les autres créatures du jeu de base et ont été fait à partir d'une créature agressive à la base... Moi pas comprendre.

#2 sucresalesucre

sucresalesucre

    En fait y'a des accents cachés


Posté 07 avril 2009 - 12:25

Est ce que ton Gecko ne devrait pas utiliser un Template ? (quelques des monstres le font je crois) au lieu de l'AI Data ? Sinon mettre l'AI en Very Agressive et Foolhardy, mais ça, je pense que tu l'as déjà fait  :banderilles:

Peut-être aussi que c'est au niveau des animations d'attaque qui manquent.

Pour l'instant, j'ai créé un Behémoth, il m'a bien cassé la gueule, ça marche, hum hum.

Le chat CROIT appartenir à une race supérieure évoluée. Mais ce n'est qu'un rebut pervers avec des yeux belzebuth et des griffes.


------

Moddeur de Blye Citadelle du Chaos pour Morrowind et Vault panic pour Fallout3


#3 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 07 avril 2009 - 17:32

Voir le messagesucresalesucre, le 07.04.2009 à 13:24, dit :

Est ce que ton Gecko ne devrait pas utiliser un Template ? (quelques des monstres le font je crois) au lieu de l'AI Data ? Sinon mettre l'AI en Very Agressive et Foolhardy, mais ça, je pense que tu l'as déjà fait  ;)
Normamelemnt mettre un Template ça fait pareil, ça permet de modifier toutes les créatures qui vont ensemble en un coups. C'est juste un truc de flemmard pas obligatoire.
Mais oui, faudrait que j'essaye que d'utiliser un template de créature agressive pour voir.

Voir le messagesucresalesucre, le 07.04.2009 à 13:24, dit :

Peut-être aussi que c'est au niveau des animations d'attaque qui manquent.
Les animations sont celles de l'écorcheur donc, pas de soucis de ce coté là.

#4 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 10 avril 2009 - 05:31

J'ai trouvé ce qui n'allait pas, c'est bien un histoire d'animation mais comme on pensait au départ. Dans le cas de la création d'une créature, il faut aller dans "Gameplay/Idle Animation" et ajouter des "GetUpAnims" et "HitReactions" à la créature.

#5 sucresalesucre

sucresalesucre

    En fait y'a des accents cachés


Posté 11 avril 2009 - 08:53

Voir le messageAncestral Ghost, le 10.04.2009 à 06:30, dit :

J'ai trouvé ce qui n'allait pas, c'est bien un histoire d'animation mais comme on pensait au départ. Dans le cas de la création d'une créature, il faut aller dans "Gameplay/Idle Animation" et ajouter des "GetUpAnims" et "HitReactions" à la créature.
Ca s'est bon à savoir ! Je le note dans mon cahier de textes.  :?

Le chat CROIT appartenir à une race supérieure évoluée. Mais ce n'est qu'un rebut pervers avec des yeux belzebuth et des griffes.


------

Moddeur de Blye Citadelle du Chaos pour Morrowind et Vault panic pour Fallout3


#6 Svartalfar

Svartalfar

Posté 25 février 2018 - 19:04

Bonjour messieurs-dames.

J'ai à mon tour un petit souci similaire, mais avec des créatures déjà existantes (des Trogs). J'en ai disposé à certains endroits, en extérieur comme en intérieur. Elles ont beau avoir les GetUpAnims et HitReactions, elles fuient quand même.
Avez-vous une idée de ce qui coince, sachant que j'ai utilisé des modèles uniques et non les leveled creatures (que je n'arrive pas à implanter d'ailleurs) ?




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)