Aller au contenu


Redguard Sous Xp


  • Veuillez vous connecter pour répondre
42 réponses à ce sujet

#26 d3ido

d3ido

Posté 06 March 2015 - 15:42

Salut tout le monde!

Alors voila, je viens de (ré)installer Redguard sur mon pc (qui tourne sous seven x64) mais impossible de lancer le jeu...

Je l'ai installé avec 3dfx et ai installé DgVoodoo dans le dossier de ce dernier et j'ai une fenêtre qui s'ouvre et qui me dit qu'il ne trouve pas les driver de la carte 3dfx... (j'ai bien sur essayé plusieurs fois de réinstallé mais rien ne change)
Et lorsque j'essaye de le lancer avec RGFX.exe au lieu de Redguard.exe cette foi j'ai un message au sujet de version de windows x86 / x64 quelqu'un aurais une solution ?

sinon je sait bien qu'il y a virtualbox (c'est comme ça que je l'ai fait tourner le dernier coup que j'y ai "joué") mais je voudrait vraiment pouvoir le lancer depuis seven pour qu'il ai sa petite icone de raccourcie avec les autres sur le bureau... :blush:  (geek va!!! :dry:)
Image IPB

#27 MagikMike

MagikMike

    Crétins de bugs !


Posté 06 March 2015 - 16:25

http://forums.uesp.n...hp?f=28&t=35870
Je n'ai pas essayé par contre

HS : Quels imbéciles
Tu peut parfaitement avoir une ISO d'un CD acheté. Ils n'ont jamais utilisé de logiciel de gravure? :lazy:
PNOG
PNOS

On a toujours besoin d'un petit PNO chez soi (merci Neluche)

#28 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 06 March 2015 - 18:42

Voir le messaged3ido, le 06 March 2015 - 15:42, dit :

Je l'ai installé avec 3dfx et ai installé DgVoodoo dans le dossier de ce dernier et j'ai une fenêtre qui s'ouvre et qui me dit qu'il ne trouve pas les driver de la carte 3dfx... (j'ai bien sur essayé plusieurs fois de réinstallé mais rien ne change)
Et lorsque j'essaye de le lancer avec RGFX.exe au lieu de Redguard.exe cette foi j'ai un message au sujet de version de windows x86 / x64 quelqu'un aurais une solution ?
On ne doit pas pouvoir lancer RGFX.exe directement sous Windows 64bits car cet exe doit surement être en 16bits (Comme la plupart des Exe de l'époque). Hors, windows 64bits ne supporte plus les applications 16bits (Seulement 32bits en plus de 64bits, bien sur). Du coups, obligé de passer par Dosbox comme dans le lien de Mike.

Voir le messageMagikMike, le 06 March 2015 - 16:25, dit :

HS : Quels imbéciles
Tu peut parfaitement avoir une ISO d'un CD acheté. Ils n'ont jamais utilisé de logiciel de gravure? :lazy:
Oui, surtout qu'en plus c'est même fort conseillé de passer par un ISO (Ou plutôt un combo ".cue" + ".bin" pour avoir la musique) sur ces vieux jeux. Cela rame beaucoups moins, et cela évite d'abimer son CD collector.

#29 d3ido

d3ido

Posté 06 March 2015 - 18:59

merci à tout les deux :)

par contre une âme charitable pourrait me faire une petite traduction ? (je suis pas du tout assez bon en anglais pour suivre les explication donné sans faire de gourde...)
Image IPB

#30 Shadow she-wolf

Shadow she-wolf

    Le katana de la GBT


Posté 06 March 2015 - 19:07

Je joue présentement à Redguard sur Seven 64Bits.


J'ai réussi à tout faire fonctionner avec un tuto trouvé sur la TIL, qui demande d'utiliser une version patchée de DosBox (et non l'originale, qui finit par faire buguer le jeu)

Il faut installer le DosBox par Ykhwong : http://ykhwong.x-y.net/ (section "Download", et télécharger l'exe)

Après installation, aller dans le répertoire de DosBox et supprimer le fichier "glide2x.dll".

Télécharger et installer NGlide : http://www.zeus-soft...ownloads/nglide

Éditer le fichier Dosbox.conf :
memsize=63 et glide=true
(Et éventuellement modifier la section [autoexec] pour monter l'iso et charger Dosbox dans le répertoire du jeu)

Lancer RGFX.exe via Dosbox (32Bits) et profiter du jeu !

Chez-moi ça fonctionne, par contre le FPS est trèèèèèèès variable, j'ai souvent une super-accélération à la sortie d'un menu qui dure deux-trois secondes, et ça lague dans les grandes zones (ie, dans certaines zones de la ruine dwemer par exemple)


Attention, car je me suis faite avoir la première fois : ne pas installer le jeu à la racine du disque dur.
C'est à dire pas dans C:\Redguard. Mais dans un sous-répertoire, du genre C:\jeux\Redguard. Car sinon le jeu n'arrivera pas à démarrer.

#31 d3ido

d3ido

Posté 06 March 2015 - 19:15

Merci Shadow j'aissaye ça ! :D
Image IPB

#32 d3ido

d3ido

Posté 09 March 2015 - 06:54

Bon hé bien je n'y arrive pas... -__-" Dosbox me dit qu'il lui est impossible de lancer rgfx.exe (erreur disque critique ou un truc du genre...)
Je doit être trop nul ><"

ha et aussi je n'arrive pas à trouver le "Dosbox.conf"... (j'ai fait une recherche sur tout le disque dur mais rien...
Image IPB

#33 Shadow she-wolf

Shadow she-wolf

    Le katana de la GBT


Posté 09 March 2015 - 09:02

Le fichier de config se trouve dans
C:\Users\Freyja\AppData\Local\DOSBox
Remplacer le "Freyja" par ton nom d'utilisateur. Le fichier doit se nommer dosbox-SVN-Daum.conf.

Tu modifies ces deux champs:
memsize=63 et glide=true

Et tu modifies la rubrique [autoexec], afin de pouvoir monter le CD/l'iso du jeu dans Dosbox, et de éventuellement accedéder directement dans le répertoire du jeu au démarrage de Dosbox.
Par exemple mon mien:
[autoexec]
mount c c:\games\
mount d F:\ -t cdrom -ioctl
C:

La première ligne monte le C: de Dosbox dans mon répertoire où il y a tous les jeux vidéo (dont Redguard).
La seconde ligne monte le lecteur F: de Windows (mon lecteur CD, où il y a le CD de Redguard) dans le lecteur D: de Dosbox. Ça doit être ça qui te manque, le jeu ne démarrera pas si Dosbox ne sait pas où trouver le CD du jeu.

Et la troisième ligne dit "va dans C: au démarrage".

Comme ça pour lancer le jeu, je n'ai plus qu'à faire :
cd REDGUARD
RGFX.EXE


#34 d3ido

d3ido

Posté 09 March 2015 - 11:23

bon ça ne fonctionne toujours pas mais il y a du mieux Xd ....

(si j'arrive à comprendre ce qui est écrit en anglais: ) dans le deuxième fenêtre il me parle de "cycle" qui est réglé sur auto et me demande de réessayer en le fixant... oui mais à combien ?

(et encore merci Shadow ! :P )
Image IPB

#35 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 09 March 2015 - 18:39

Essais "max"

#36 d3ido

d3ido

Posté 09 March 2015 - 18:45

non ça ne me donne rien... :/ j'ai aussi testé 10 et 20 (qui était respectivement indiquer dans le fichier comme "cyclesup" et cyclesdown" ...)

j'ai réinstallé et réessayé mais rien non plus ...
Image IPB

#37 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 09 March 2015 - 20:01

Si cela ne fonctionne pas avec "max", c'est que le problème vient d'ailleurs.

#38 d3ido

d3ido

Posté 09 March 2015 - 21:19

j'ai réussi à mettre dos en français ! (comment ça c'est pas un exploit ???) du coup je comprend un peut mieux...
Il me dit, lorsque je tape : "cd Redguard" qu'il est impossible de charger vers Redguard
Le problème doit venir de là non ? il ne charge pas le cd c'est bien ça?


Bon j'ai finalement réussi!!!!

le problème venait du fait que je montait "C" directement dans le dossier d'installe de Redguard...

en gros je le montait dans "F:/Jeux/Redguard/" alors qu'il fallait le monter dans "F:/Jeux/ " puis exécuter "cd redguard" et enfin "rgfx"

ne me reste plus qu'a réussir à mettre le son :P

Modifié par d3ido, 09 March 2015 - 21:59.

Image IPB

#39 Shadow she-wolf

Shadow she-wolf

    Le katana de la GBT


Posté 09 March 2015 - 21:58

Non, cela veut dire qu'il ne connait pas le répertoire "Redguard".

La commande "cd Redguard" que j'utilise, c'est parce que mon dosbox ne démarre pas dans le répertoire du jeu, mais dans le répertoire parent. Quand j'entre cette commande, c'est pour dire "va dans le répertoire du jeu", c'est tout.

Si toi tu es déjà dans le répertoire du jeu, tu n'en as pas besoin.


En fait, faudrait que tu nous dises où tu as installé Redguard, et que tu nous passes le contenu de ton [autoexec] du fichier de configuration.


Edit : bon, tant mieux si ça marche finalement. :D

#40 d3ido

d3ido

Posté 10 March 2015 - 07:43

Bon bha c'est mal partie pour le son maintenant... -__-"

En suivant le wiwiki :
pour commencer, après avoir installé VDM Sound,  dans la partie Utilisation de VDM Sound :
  • faites un clic-droit sur SETSOUND.EXE et choisissez Run with VDMSound.
On ne me propose pas "run with vdm sound" j'ai essayez des glissé/déposé mais sans résultat (incompatibilité de dvm avec win 64 bits)j'ai donc essayer de le lancer dans dosbox mais là il me dit qu'il ne peut tourner que sous windows NT...

Ensuite dans la partie Utilisation de Sapucdex:
après avoir décompressé l'archive au bon emplacement :
  • Ouvrez le fichier autoexec.nt avec un éditeur de texte et remplacez la ligne lh %SystemRoot%\system32\mscdexnt.exe par la ligne lh %SystemRoot%\system32\sapucdex.exe
je n'ai aucun fichier "autoexec.nt" que ce soit dans l'archive, dans system32 ou même dans les fichier de Redguard...

impossible donc d'avoir le moindre son... :/

(je sent que je vais faire une petite mise à jour sur le wiwiki moi après XD )

Modifié par d3ido, 10 March 2015 - 07:44.

Image IPB

#41 Ancestral Ghost

Ancestral Ghost

    Chasseur furtif


Posté 10 March 2015 - 22:48

Le tuto sur le Wiwiki est pour faire tourner le jeu sous Windows XP directement (Donc sans Dosbox, mais avec d'autres logiciels comme VDM Sound). Toi tu es partis sur une option avec Dosbox, tu dois donc configurer le son dans Dosbox. Mélanger les tutos ne fera que t'embrouiller.

Tous les vieux jeux de cette époque avait un executable pour lancer la configuration du son, pour Redguard c'est "setsound" comme indiqué dans le lien de Mike :

Citation

mount c ".\Redguard\sound"
c:
setsound

-General/midi set to Sound Blaster 16 with automatic values.
Donc lancer le fichier "setsound" se trouvant dans le sous dossier "sound" (Donc faire "cd sound" pour y aller depuis le dossier du jeu ou se trouve "rgfx") puis configurer les options Sound Blaster dans le logiciel de configuration qui a du se lancer.

Sinon, je suis d'accord qu'il faudrait mettre à jour les tutos dans le Wiwiki, il s'agit de vieux tutos pour XP qui ne sont plus valables sur Windows Vista/7/8/10.

#42 d3ido

d3ido

Posté 11 March 2015 - 07:55

Merci Ghost,

j'avais en effet essayé la méthode dont tu parle mais sans avoir plus de résultat... la configuration est bien enregistré mais le son toujours absent...

j'ai fait :

Sound Configuration Options
>>Select and configure MIDI music driver
>>>>Creative Labs Sound Blaster or 100% compatible
>>>>>>Attempt to configure sound driver automatically
[là il me dise "Device detected successfully]
>>OK (retour au menu)
Sound Configuration Options
>>Select and configure digital audio driver
>>>>Creative Labs Sound Blaster or 100% compatible
>>>>>>Attempt to configure sound driver automatically
[réponse: "Device detected successfully]
>>OK (retour au menu)
Sound Configuration Options
>>Done

mais toujours aucun son... je pense avoir fait le tour de tout les pilotes proposé et fait un test à chaque foi que la réponse au pilote était positive... :/

ps: j'ai commencé un nouveau tuto pour le wiki, par contre il faudra sans doute un ortho-puriste quand j'en aurais fini ><"
Image IPB

#43 qutais763

qutais763

Posté 28 April 2015 - 08:07

merci en retard ! j'ai essayé déjà, ça fonctionne bien !






------------------------------------------------------
housse galaxy s6 edge coque galaxy s6 edge

Modifié par qutais763, 29 April 2015 - 02:33.





0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)